This Data Protector error message started to appear at the beginning of back-up jobs and caused the sessions to fail.

Here is a workaround for this problem:
Firsly find the device path of your tape library on the backup manager server with the following command:

$ioscan -fnC autoch
Class I H/W Path Driver S/W State H/W Type Description
=========================================================================
autoch 0 13/0/6/1/0.1.23.255.0.0.0 schgr CLAIMED DEVICE HP ESL E-Series
/dev/rac/c26t0d0

Then following uma commands show what the drives are doing and status of the slots.

$uma -ioctl /dev/rac/c26t0d0
*** PROGRAM: UMA VERSION: HP OpenView Storage Data Protector A.06.00

*** (c) Copyright Hewlett-Packard Company 2006
*** License is restricted for use with licensed
*** HP OpenView Storage Data Protector products.
/dev/rac/c26t0d0>
/dev/rac/c26t0d0> stat D
4096 D1 Full "" "" from S21
4097 D2 Full "" "" from S23
4098 D3 Empty "" ""
4099 D4 Empty "" ""
4100 D5 Empty "" ""
4101 D6 Empty "" ""
4102 D7 Empty "" ""
4103 D8 Empty "" ""
4104 D9 Full "" ""
4105 D10 Empty "" ""
4106 D11 Empty "" ""
4107 D12 Empty "" ""
4108 D13 Empty "" ""
4109 D14 Full "" ""
4110 D15 Empty "" ""
4111 D16 Empty "" ""
4112 D17 Empty "" ""
4113 D18 Empty "" ""
4114 D19 Empty "" ""
4115 D20 Empty "" ""
4116 D21 Empty "" ""
4117 D22 Full "" ""
4118 D23 Empty "" ""
4119 D24 Empty "" ""

/dev/rac/c26t0d0> stat S
12288 S1 Full "" ""
12289 S2 Full "" ""
12290 S3 Full "" ""
12291 S4 Full "" ""
12292 S5 Full "" ""
12293 S6 Full "" ""
12294 S7 Full "" ""
12295 S8 Full "" ""
12296 S9 Full "" ""
12297 S10 Full "" ""
12298 S11 Full "" ""
12299 S12 Full "" ""
12300 S13 Full "" ""
12301 S14 Full "" ""
12302 S15 Full "" ""
12303 S16 Full "" ""
12304 S17 Full "" ""
12305 S18 Full "" ""
12306 S19 Full "" ""
12307 S20 Full "" ""
12308 S21 Empty "" ""
12309 S22 Full "" ""
12310 S23 Empty "" ""
12311 S24 Full "" ""
12312 S25 Full "" ""
12313 S26 Full "" ""
12314 S27 Full "" ""
12315 S28 Full "" ""
12316 S29 Full "" ""
12317 S30 Full "" ""
.
.
.
The problem can be seen with the stat D output. Drives 1,2,9,14 and 22 are "full" but there are no backup jobs running. Now we should move the tapes into empty slots with following uma commands.

/dev/rac/c26t0d0> move D1 S21
/dev/rac/c26t0d0> move D2 S23
/dev/rac/c26t0d0> move D9 S55
/dev/rac/c26t0d0> move D14 S56
/dev/rac/c26t0d0> move D22 S57

Now all the drives seems to be empty. When we re-run the backup job we won't see the "Cannot load exchanger medium (Target drive is busy.)" error message but we must do one thing more to avoid future errors.

On the Data Protector Manager GUI select devices and media --> devices --> right click on the library --> select properties --> on the control tab --> under the busy drive handling topic --> select "Eject Medium" (not abort)



This avoids the same problem to occur again, because when the library experience a busy drive problem it will eject the medium.

One Response so far.

  1. Alejandro says:

    Thank you, four your help!

DOAG 2016

Powered by Blogger.

Page Views

- Copyright © Emre Baransel - Oracle Blog -Metrominimalist- Powered by Blogger - Designed by Johanes Djogan -