RMAN-03009 ORA-19554 ORA-27211 (2)

.

This is the second post for the same error:


RMAN-00571: =======================================
RMAN-00569: ======= ERROR MESSAGE STACK FOLLOWS =======
RMAN-00571: =======================================
RMAN-03009: failure of allocate command on t1 channel at 08/03/2010 19:57:21
ORA-19554: error allocating device, device type: SBT_TAPE, device name:
ORA-27211: Failed to load Media Management Library

First one was about lack of soft links under library directories.
http://emrebaransel.blogspot.com/2009/01/rman-03009-ora-19554-ora-27211.html

This one is about EMC networker misconfiguration.



What i was doing is restoring a database backup to another host. Backup was taken form server1 and i was trying to restore to server2.
After having the above error, i restarted the restore with debug mode in order to investigate the underlying problem. Following "allocate channel" command produces a debug file under specified directory.

allocate channel t1 type 'SBT_TAPE' parms 'ENV=(NSR_SERVER=bcksrv, NSR_CLIENT=server1, NSR_DATA_VOLUME_POOL=DAILYPOOL, NS
R_DEBUG_FILE=/home/oracle/RMAN/debug1.log)';

I found the following error in the debug file:

SBT-8233 08/03/10 22:22:50 lnm_index_cfx_pconn: The NW authentication for client 'server1' was refused by server 'bcksrv' be
cause 'User oracle on computer server2 is not on server1's remote access list'. (2:12:13)

Adding server2 to the server1's remote access list solved the problem. On NetWorker Administration interface, first choose "Configuration" tab, click "Clients", right-click "server1" and choose properties. Selects "Globals" tab and add the following line to "Remote access" box:
oracle@server2

0 comments: